OpenPandora Main OS

This project it to track issues relating to the current shipping OS only as found here Please state what Hotfix you are running with any issue report. Please ONLY use this to record issues for the main OS and its default included applications - any other application issue reports should go into the Additional Applications project. Issue reports with 'in development OS images' or feature requests for the next MAJOR version (not Hotfix release) should be placed into the OpenPandora Development OS project and reported on the mailing list Please read this page to find out how to properly report bugs:

IDCategoryTask Type  ascSeveritySummaryStatusProgress
265ApplicationBug ReportMediumMiniMenu: Flawed tab display of sub-categories if they ...Unconfirmed
Task Description I assigned personal subcategories to some of my games. Some of those subcategories share the same beginning string, i.e: Shooter, ShooterBallistic ShooterScoller. MiniMenu displays those subcategories with flaws! See the ASCII screenshots below. Note: The star symbols indicate the currently active selection. The main category tab "Game" being active: ---------------------------------------------------------- | All | Audio | AudioVideo | Education |*Game*| Graphics | ---------------------------------------------------------- ActionGame AdventureGame ArcadeGame BlocksGame ... Shooter ShooterBallistic ShooterScroller ... GameA GameB GameC ... ---------------------------------------------------------- Now if I navigate into the sub-category "Shooter", everything normal: ---------------------------------------------------------- |*Shooter*| ---------------------------------------------------------- .. ShooterA ShooterB ShooterC ... ---------------------------------------------------------- But if I navigate to the sub-category "ShooterBallistic", strangely MiniMenu shows 2 tabs, "Shooter" and "ShooterBallistic", and jumps right into "Shooter". ---------------------------------------------------------- |*Shooter*| ShooterBallistic | ---------------------------------------------------------- .. ShooterA ShooterB ShooterC ... ---------------------------------------------------------- In order to reach my intended tab "ShooterBallistic" I need to navigate to it again. Annoying. There the contents are as expected: ---------------------------------------------------------- | Shooter |*ShooterBallistic*| ---------------------------------------------------------- .. ShooterBallisticA ShooterBallisticB ShooterBallisticC ---------------------------------------------------------- The flaw is the same for all other sub-categories beginning with "Shooter...". All have the flaw as shown in the example "ShooterBallistic", only that it is themselves instead of "ShooterBallistic". One more example to be perfectly clear: ---------------------------------------------------------- | Shooter |*ShooterScroller*| ---------------------------------------------------------- .. ShooterScrollerA ShooterScrollerB ShooterScrollerC ----------------------------------------------------------
 277 CoreBug ReportMedium SuperZaxxon B3: minimenu does not scan all folders Closed
Task Description Using SuperZaxxon beta3 (already observed it with beta2) it seems as if minimenu is not scanning all folders (and subfolders) correctly. Please have a look at this post for more information:
 289 ApplicationBug ReportMedium "sudo find /" produces assertion Closed
Task Description $ sudo find / find: ftsfind.c:477: consider_visiting: Assertion `ent->fts_info == 11 || state.type != 0' failed. Aborted This is fixed by updating findutils to latest version using sudo opkg upgrade findutils Release SuperZaxxon 1.5 (not Beta 3, as given in "Reported Version" field, but there the release cannot be chosen).
290CoreBug ReportMediumgnome-mount not availableUnconfirmed
Task Description In GTK applications, such as Truecrypt, NoteCase Pro or Mousepad, the file open / file save dialogs have shortcuts to mounted file systems on the left side. If clicking such a shortcut entry, the corresponding file system's contents are shown in the right dialog pane. This works for file systems, which were available at boot time. For file systems mounted after booting, e.g. by inserting an SD card or connecting a USB drive, when clicking such an entry, an error message appears saying "Could not mount [volumen name] Failed to execute child process 'gnome-mount' (No such file or directory)" This is healed by sudo opkg install gnome-mount (which instals gnome-mount, nautilus, gvfsd-ftp, gvfs (upgrade), and a lot of libs (upgrades).. This has been seen in SuperZaxxon release 1.5, not in Beta3 (but Beta3 is the only choice in Flyspray's dropdown currently). I reported that error for HF6 I think, and it seemed to be fixed in SuperZaxxon Beta5. A regression?
291CoreBug ReportMediumroot-owned pndrun_...out file makes PND refuse startingAssigned
Task Description If a PND has been run as root before (using from a root shell) and afterwards it is invoked the normal way, the PND doesn't start, because the .out file cannt be overwritten: /usr/pandora/scripts/ line 26: /tmp/pndrun_firefox.out: Permission denied Desired solution: .out file is silently overwitten. Maybe, if that's not possible, create another .out file with a different name (added counter, for example). Seen in SuperZaxxon relese 1.5, not in Beta3 as this task is flagged, but there is no choice besides Beta3.
301CoreBug ReportMediumMissing X keybinding for colon symbolUnconfirmed
Task Description As verified with xev, an attached bluetooth keyboard can not generate colon (shift semicolon). xmodmap shows that (unlike a standard Linux system) shift-semicolon is mapped to NoSymbol. While it's find that there's a special symbol to get semicolon on the built-in keyboard, the other binding really should be there in support of attached keyboards.
 310 CoreBug ReportMedium mkdosfs is broken - creates 1GiB filesystems Closed
Task Description When a partition is bigger than 2 or 4 GiB (can't recall now) it makes a "default" 1GiB filesystem. Propably missing large file support in the build. Also, the pandora sd card formatter is missing -F 32 so it makes (i think, it is some time from when I noticed this) FAT16 partitions...
 311 CoreBug ReportMedium [PATCH] Thunar configurable trash Closed
Task Description Not my work, but since I think my reply to ED on the forums will get buried I made this report. The post with patch:
315CoreBug ReportMediumPairing bluetooth SPP devices doesn't work with XFCEUnconfirmed
Task Description Hi, sadly the XFCE bluetooth manager seems to have problems with pairing simple SPP devices (an BT GPS mouse here). 1. Enable BT 2. BT Manager -> Add new device 3. Confirm Dialog and wait for scanning 4. Pick device 5. Select PIN options -> "0000" (here for me) In next step the dialog still asks you to enter a random PIN at your BT device (which is impossible here). Thus it seems, that the XFCE dialog makes troubles, I tried it with 2 different GPS. Pairing the GPS manually works fine: sudo rfcomm connect rfcomm0 00:18:E4:26:5F:14
 317 CoreBug ReportMedium After disabling USB-host current still flows into USB d ...Closed
Task Description On my Pandora, due to bad internal WiFi, I use an Edimax EW-7811Un USB WiFi adapter, which has a status-LED, flickering according to the network activity. After disabling USB-host through the settings menu, the WiFi functionality is gone, but the device's LED is still on. So some current must still flow into the USB device. The LED now has a permanent light, no flickering! This lack of "device intelligence" indicates that the device was indeed turned off, just current flowing directly to the LED circuit unaltered). I can repeat the aforementioned steps many times, the behavior is the same. As soon as I then first physically unplug and reinsert the device, the LED remains off eventually. From then on, every further issuing of "Disable USB-host" through the settings menu turns the device LED completely off. Smells like a kernel bug to me! As it requires one real un/re-plugging, from then on works ok.
 323 CoreBug ReportMedium OS Selector bug Closed
Task Description

When selecting no OS in the OS Selector you're returned to the login screen where you have to reauthenicate. (Pressing Enter without selecting an OS does this)

I happen to do this a lot and it drives me mad :P

331CoreBug ReportMediumHold switch key continuously sends X11 KeyPress events ...Unconfirmed
Task Description

When put into Hold mode, X11 handles the power switch as if it's being pressed, and it generates lots of keypress events, passing them to the foreground application. Since /dev/input/eventX does not seem to continuously trigger, I'm guessing it's due to key repeat.

To reproduce:

  • Install xev and open it in the terminal
  • Put the power key in HOLD mode
  • Notice the "time" value changing rapidly

In addition to causing more work to X, it also floods the active application with key presses, resulting in increased CPU usage. In my test, switching to HOLD while Firefox is in the foreground causes it to use 6% CPU and X an additional 2.5%.

In addition, the key-press events continue even after the switch is taken off HOLD until another key is pressed.

A possible solution to this is to blacklist the power-button event device, to prevent evdev from listening to it (the key is handled by pndevmapperd).

 332 CoreBug ReportMedium and scripts fail for some ...Closed
Task Description

/usr/pandora/scripts/ and /usr/pandora/scripts/ fail for some usernames due to poor shell scripting


these scripts find their config files by grepping /etc/passwd for the uer currently running xfce4-session, but the loose regexp matches too much. this shell fragment from


grep /etc/passwd -e $(ps u -C xfce4-session | tail -n1 | awk '{print $1}')| cut -f 6 -d ":"


when a use called "me" is logged in, returns







rather than just "/home/me"


all instances of that construct (reading and writing settings, in both and should be changed to


grep /etc/passwd -e ^$(ps u -C xfce4-session | tail -n1 | awk '{print $1}'): | cut -f 6 -d ":"


to correctly match only the complete username field in /etc/passwd

336CoreBug ReportMediumTouch screen sensitivity too lowUnconfirmed
Task Description

The touch screen requires to be used with the stylus or another sharp object. Even if I need to click a desktop icon, and could as well use my finger, the touch screen won't react to my finger at all (even if pressed quite hard).

 4 CoreBug ReportLow Missing Icons Closed
Task Description Some icons are missing: XFCE4 Settings Manager: Accessibility, Appearance, Desktop, Display, File Manager, Keyboard, Mouse The icons on the panel (Mail, Web, etc.) are also missing (they're invisibile)
 7 CoreBug ReportLow No help or tips and tricks yet Closed
Task Description Help is missing as are the tips and tricks on startup.
 20 CoreBug ReportLow pndevmapperd: / Closed
Task Description pndevmapperd tries to run /usr/pandora/scripts/, however, the filename is /usr/pandora/scripts/ Either rename the file or change the call ;)
 21 CoreBug ReportLow doesn't work correctly Closed
Task Description The file has to be changed to make it work. The working script is: #!/bin/bash #get value range minbright=3 maxbright=$(cat /sys/devices/platform/twl4030-pwm0-bl/backlight/twl4030-pwm0-bl/max_brightness) curbright=$(cat /sys/devices/platform/twl4030-pwm0-bl/backlight/twl4030-pwm0-bl/brightness) device=/sys/devices/platform/twl4030-pwm0-bl/backlight/twl4030-pwm0-bl/brightness if [ ! $1 ]; then newbright=$(DISPLAY=0:0 zenity --scale --text "set brightness" --min-value=$minbright --max-value=$maxbright --value=$curbright --step 1) else newbright=$1 fi if [ $newbright -le $minbright ]; then newbright=$newbright; fi echo $newbright > $device
 22 CoreBug ReportLow pndevmapperd: Powerbutton / hold doesn't work. Closed
Task Description Moving the powerbutton doesn't get recognized by pndevmapperd. When moving the powerbutton to hold, it reports: keyboard.c: can't emulate rawmode for keycode 152
 24 CoreBug ReportLow not working Closed
Task Description Reports: xfce4-appfinder: Cannot open display: . Fix might be (according to vimacs): Change those two similar looking lines to: sudo -u $xfceuser DISPLAY=:0.0 xfce4-appfinder and: pidlist=$(pstree -lpA | grep | sed -ne 's/.*-\(.*\)(\([0-9]\+\))/\2\n \1/p' | DISPLAY=:0.0 zenity --list --multiple --column "pid" --column "name" --title "kill" --text "which apps should be killed" | sed 's/|/\n/') Needs to be checked.
 27 CoreBug ReportLow xfce4-brightness-plugin: 0 isn't a good minimum value Closed
Task Description The xfce4-brightness-plugin can be set to a minimum of 0. This is kinda confusing to the normal user, as it makes the screen totally black. Maybe this could be changed to a minimum of 3?
 32 CoreBug ReportLow pndnotifyd: Crawling through directories it shouldn't i ...Closed
Task Description My current configuration is: Rootfs on first SD Card, 2nd partition. If I put my WIZ SD Card with tons of files into the second SD Slot while booting, pndnotifyd eats up about 95% of CPU time. After about 8 - 9 minutes, it stopped eating the CPU and the system is working normally. This doesn't happen when I put in the card when XFCE4 is already running. Using LSOF, I can confirm it's crawling where it shouldn't: pndnotify 1825 root 6r DIR 179,9 1441792 62488 /media/mmcblk1p1/roms/c64/Tapes Could it be that on first initialization it hasn't loaded the config and crawls through the whole SD Card? On a side note: I got 44700 files on that SD Card... so if it needs about 8 minutes, that does mean it can do over 5000 files a minute!
 33 CoreBug ReportLow mmcqd eating lots of CPU power when writing Closed
Task Description EDIT: Tried a remount with noatime and this seemed to work very well. CPU usage when writing still goes higher, but not as high as before. Very common problem, seems to happen on all systems (just do a google search for mmcqd). Just run SuperTux, wait about 10 seconds at the title screen and it will hang for a few seconds (while mmcqd goes up). Same problem as on the GP2X where we also had hangs occuring. I wonder if there's something that can be done here? Some suggest to change mmcqd priority. Some other sites do try to remove features of mmcqd. Another option is to mount async (like on the gp2x). As the Pandora usually isn't switched off the hard way but should be shutdown properly, this could be a good solution. That would mean that our suspend mode needs to call sync before shutting down. Maybe could also run sync after a game quit? Here are some interesting reads that might help us: : "wait_for_completion is blocking call. Please check 'omap_mmc_request'" - He disables some stuff in mmcqd which lowers CPU usage.
 35 CoreBug ReportLow AbiWord crashes when you try to start the help. Closed
Task Description Starting the Help Center will freeze AbiWord.
 36 CoreBug ReportLow X doesn't restart in No-X mode ( Closed
Task Description At the end of the script, it calls /etc/init.d/slim-init-init start If you fix that to /etc/init.d/slim-init start , X restarting works again. Please apply this fix into the GIT.
 40 CoreBug ReportLow pmenu doesn't show screenshots Closed
Task Description I did create some PXML files which have screenshots included. pmenu seems to ignore them, it just shows a red X.
 41 CoreBug ReportLow netbook-launcher-efl: Shutdown / Logout / Reboot not wo ...Closed
Task Description The netbook-launcher displays the logout / reboot / shutdown dialogue, but doesn't do anything when you select anything.
 42 CoreBug ReportLow sed needs sudo access Closed
Task Description I (EvilDragon) created a small script where you can reselect the default GUI and enable / disable autologin. Works fine so far, except for that the sed to /etc/slim.conf needs root access. I have no idea how to make sudo in this script work without asking for a password. If anyone could help me there, I'll be happy :)
 53 CoreBug ReportLow Non-X Touchscreen: Inverted axis Closed
Task Description Running SDL-Apps in Non-X mode have inverted axis.
 67 CoreBug ReportLow libpnd : pnd_apps_exec() function bug Closed
Task Description libpnd : pnd_apps_exec() do not seems to be up to date with script, when executing the function i get from the terminal : getopt: invalid option -- 'c' Terminating...
 68 CoreBug ReportLow AlephOne PND not running Closed
Task Description I don't even know if this is a bug or if I just happen to have a fault in my PXML file. All multi-apps-PNDs I have do run fine - except for AlephOne. Whether I include the datafiles or keep them external, it won't work. I can manually mount it ( -p /bla.pnd -m ) and run it from the mounted directory, but it does not do so automatically from the desktop file. If one of you two could check that out, that would rock. You can download it from the usual PND-Repo I use ;)
 71 CoreBug ReportLow Permissions of omapdss need to be fixed Closed
Task Description Only root can currently setup and change TV Out parameters :) Should be set to make it user-changeable.
 77 CoreBug ReportLow Shut down screen Closed
Task Description The shut down screen says "booting...". :)
 79 CoreBug ReportLow On clean install, picking minimenu as a GUI hangs the p ...Closed
Task Description I had to reboot the pandora (look in the manual :)) to get back to the installer. I had to specify ANOTHER user, as the one I made was still there. Picking the XFCE one did work.
 80 CoreBug ReportLow After bug 79, the user manager doesn't list my users Closed
Task Description And when i try to remove anyway, it tries to remove user (null). I didn't have the guts to say 'Yes, remove user'
 83 Base OSBug ReportLow getting more /media/mmcblk?p1  Closed
Task Description From a conversation with skeezix: I'm seeing /media/mmcblk0p1, mmcblk1p1, mmcblk2p1, mmcblk3p1 and mmcblk4p1 - is that something I should worry about? This started after I inserted & ejected my sd card a couple of times. To which skeezix said: The system starts at /media/mmcblk0 (with p1 ec being the partition number); if you eject the SD, then stick it back in, it will try to go to the earlier number again, but if some process was watching that SD when you ejected it, the system will nto be able to recycle that number, so you get the next blk number. So if you end up with /media/mmcblk5p1 (say), then it means you've been eject/inserting, and some program or another has been watching the SD instead of letting it go. Isn't it nicer to cleanup the ones above 1 (so 0 and 1 are there) at startup to avoid confusion?
 84 ApplicationBug ReportLow Bluetooth stays on Closed
Task Description You can enable Bluetooth, but can't disable it afterwards from the system -> toggle bluetooth menu shortcut.
 93 Base OSBug ReportLow zaxxon first boot: don't ask for user prompt if already ...Closed
Task Description How to reproduce: First boot, Pandora's Box has been opened. Prompt for Full name, username, and password. Then, simply press OK without selecting whether minimenu or xfce. None selected. Then you can't do any more. Wizard closes and you don't need any more options. After manual reboot, the wizard starts again and asks for name again. But the username already exists.
94CoreBug ReportLowBacklight control by lid sensor not detected after bootNew
Task Description If you boot the system with the lid closed, the backlight will still be on when you get to the desktop. You have to lift the lid for an instant and then close again to shut it off. Perhaps this is because of the lack of trigger for an interrupt since the sensor is already activated. Can there be one extra check of the lid sensor after boot to cover this static position?
 100 CoreBug ReportLow Demos & Examples - remove from image Closed
Task Description /usr/bin/qt4/demos is 9Mb in size and /usr/bin/qt4/examples is 11Mb. I'm guessing these are only useful for developers. Can they safely be removed? edit: additionally, /usr/share/vim is 12M. Can those of us who are never going to use VIM remove it?
104Base OSBug ReportLowAAC decoder libfaad doesn't appear to be compiled as fi...Unconfirmed
Task Description FAAD2 appears to not be compiled with fixed point decoding. My version of libfaad compiled with fixed point used 2-3x less cpu than the provided one. It's not enough to provide the switch to the configure script. the file libfaad/common.h has to be edited and a define uncommented. Line 68 in the v2.7 source. /* COMPILE TIME DEFINITIONS */ /* use double precision */ /* #define USE_DOUBLE_PRECISION */ /* use fixed point reals */ //#define FIXED_POINT
 107 Base OSBug ReportLow Secure Wifi will not connect until XFCE is loaded Closed
Task Description My Pandora is set to load MiniMenu on boot. I can't use any networked apps because wifi will not automatically connect on boot. XFCE needs to be loaded at least once so that i can enter my keychain password. Once i've entered my password Wifi connects and i can return to MiniMenu.
 114 ApplicationBug ReportLow Chromium browser does not support HTTPS/SSL Closed
Task Description The Angstrom version of Chrome/Chromium web browser fails to open https links. This is a bug which has been fixed upstream, but not in the version packaged for Pandora.
 116 ApplicationBug ReportLow Freetype issues (freeciv sdl client) Closed
Task Description With the SDL client for freeciv the font characters show up as square blocks and garbage characters. This may be related to freetype. I had also heard that battle at wesnoth had similar issues.
 117 ApplicationBug ReportLow Quake1 / Nanogl Lockup Closed
Task Description After the last TI gles driver update quake1 (vanilla glquake 1 sources) and nanogl started to lockup the pandora after a few minutes of gameplay. Oddly all the other apps using nanogl seem stable. There is some bad code in nanogl (missing/null function pointers), which I need to clean up and afterwards reevaluate this issue.
124Base OSBug ReportLowifup doesn't like dhclientUnconfirmed
Task Description I added: iface usb0 inet dhcp And ran: ifup usb0 But dhclient simply prints usage.
 125 CoreBug ReportLow wrong error handling in wl1251 platform initilization Closed
Task Description in;a=blob;f=arch/arm/mach-omap2/board-omap3pandora.c;h=c6637426bf3a61f5bd0f85338304d0d8d114f67d;hb=HEAD I see: 555 ret = gpio_request(PANDORA_WIFI_IRQ_GPIO, "wl1251 irq"); 556 if (ret < 0) 557 goto fail_nreset; the goto should go to: fail_irq instead of fail_nreset Denis
 134 CoreBug ReportLow please add a working phonon backend Closed
Task Description Please see : :)
135ApplicationBug ReportLowOOM Killer causes loss of items in xfce4-panel configur...Unconfirmed
Task Description When the Pandora runs out of memory and the Out-Of-Memory killer fires, the Applications/Settings/xfce4/panel/panels.xml loses the entries for the menu button and the power monitor.
138CoreBug ReportLow'del' key (shift+backspace) not workingNew
Task Description The title says everything: The 'del' key does not work. In theory you should have a del "event" when hitting shift+backspace. This is not the case in all progs I tested so far (terminal and default text editor with gui).
Showing tasks 101 - 150 of 311 Page 3 of 7 - 1 - 2 - 3 - 4 - 5 - Last >>

Available keyboard shortcuts


Task Details

Task Editing