All Projects

IDProjectCategoryTask TypeSeveritySummaryStatusProgressOperating System
 311 OpenPandora Main OSCoreBug ReportMedium [PATCH] Thunar configurable trash Closed
Release 1 (Zaxxon) Task Description Not my work, but since I think my reply to ED on the forums will get buried I made this report. The post with patch:
 310 OpenPandora Main OSCoreBug ReportMedium mkdosfs is broken - creates 1GiB filesystems Closed
Release 1 (Zaxxon) Task Description When a partition is bigger than 2 or 4 GiB (can't recall now) it makes a "default" 1GiB filesystem. Propably missing large file support in the build. Also, the pandora sd card formatter is missing -F 32 so it makes (i think, it is some time from when I noticed this) FAT16 partitions...
 305 OpenPandora Main OSCoreBug ReportLow [PATCH] bluetooth startup doesnt restore enabled state Closed
Release 1 (Zaxxon) Task Description doesnt remember to call in the startup case. Patch inlined here (maybe broken, but for fast reading) and behind link: --- 2012-11-24 01:54:53.000000000 +0000 +++ 2012-11-24 02:06:51.000000000 +0000 @@ -7,8 +7,13 @@ cd "$HOME" if [ "$1" = "startup" ]; then - [ -f "$LOCK" ] && sudo /usr/sbin/hciconfig "$INTERFACE" up pscan 1>/dev/null && sudo /usr/sbin/bluetoothd || echo "Bluetooth: User has not enabled Bluetooth." - + if [ -f "$LOCK" ]; then + sudo /usr/pandora/scripts/ 1 + INTERFACE="`hciconfig | grep "^hci" | cut -d ':' -f 1`" + sudo /usr/sbin/hciconfig "$INTERFACE" up pscan 1>/dev/null && sudo /usr/sbin/bluetoothd + else + echo "Bluetooth: User has not enabled Bluetooth." + fi else # Figure out if Bluetooth is running or not
 304 OpenPandora Main OSCoreBug ReportLow bluetooth serial port sleep causes lost / frozen connec ...Closed
Release 1 (Zaxxon) Task Description I experienced (reliably) 3 times that if I had an idle ppp/rfcomm connection to my phone, it would eventually freeze so that the phone reported no active bluetooth connection and the pandora ppp would still think that the connection is active, but no data would flow. Killing pppd and re-trying would fail opening of the rfcomm link with "Host is down". Disabling & enabling bluetooth "fixed" this so that pppd worked again (so it is not the phone that was "down"). Adding these lines to (apparently atleast) fixed it for me: add between lines 14-15: echo 0 > /sys/devices/platform/omap_uart.0/sleep_timeout (or at any place during enable for that matter) And to disable (before exit 0, line 30) to save power when bluetooth is off and restore normal settings: echo 10 > /sys/devices/platform/omap_uart.0/sleep_timeout I remember mentioning this way back when I last tested bluetooth, but got a reply that this should not be needed because we have flow control between the bt chip and pandora. But if a sleeping serial port loses a character when somebody sends a burst to it, what could flow control do? If it reported not ready to receive, the character would never be sent (and things would freeze...). If it reports ready to receive (what I think it does) the character will be lost. One would need to periodically disable the serial port sleep (and enable ready to receive) for a moment to check for pending data, but I think this would use more power than keeping the serial port active and/or possibly cause way too big delays. I'm not really certain of this thing (whether this is a workaround, hack or a real fix... and whether my interpretation of what is happening is correct - i have no real proof), but I think that reporting what I've found is better than not. (And am I the only user of bluetooth with an old phone for internet (ppp+rfcomm, not pan)? ...)
 303 OpenPandora Main OSCoreBug ReportLow pppd 2.4.3 has a bug, recommend upgrade to ppp 2.4.5  Closed
Release 1 (Zaxxon) Task Description pppd 2.4.3 doesnt auto reconnect (in my setup) even if configured to do so (persist). Found a ppp bug report confirming this (;user=guest - "ppp-2.4.3 / pppoe not reconnecting") and that it has been fixed. I compiled pppd 2.4.5 and that reconnects just fine.
 197 OpenPandora Main OSCoreBug ReportHigh [PATCH] Fix opp if booting with wrong settings in hw Closed
Release 1 (Zaxxon) Task Description Hi, This should help with cases like this Patch attached.
 196 OpenPandora Main OSCoreFeature RequestMedium [PATCH] Add tablet support into kernel Closed
Release 1 (Zaxxon) Task Description Hi, This should be a quite simple thing, but my first time touching the OE repo and i cant test it, so be careful.
 172 OpenPandora Main OSCoreBug ReportLow Angstrom repo's bison is borked (FYI) Closed
All Task Description This is how it tries to call m4 (strace -fF'd): [pid 4231] execve("/OE/angstrom-dev/sysroots/x86_64-linux/usr/bin/m4", ["/OE/angstrom-dev/sysroots/x86_64"..., "/usr/share/bison/m4sugar/m4sugar"..., "-", "/usr/share/bison/yacc.c"], [/* 38 vars */]) = -1 ENOENT (No such file or directory) Problem = obvious. This is here because a) it is the bison that i get with opkg install bison and b) because i could find a general purpose bugtracker for stuff in the angstrom repo with a single googling. Added info on bison version, etc: pandora:/media/mmcblk0p3/dev/avrdude-5.6# opkg info bison Package: bison Version: 2.3-r5.0.5 Depends: libc6 Provides: Status: install user installed Section: devel Architecture: armv7a MD5Sum: c8e62fa82a96e9bba4c014c4345062ed Size: 181368 Filename: bison_2.3-r5.0.5_armv7a.ipk Description: GNU Project parser generator (yacc replacement). Installed-Time: 1283127122
 153 OpenPandora Main OSApplicationFeature RequestLow [PATCH] HACK: change OPP level according to set Mhz Closed
All Task Description It's a hack, use on your own risk as always. I feel like abusing the tracker dropping all my patches here, but whatever. Patch attached.
 151 OpenPandora Main OSBase OSFeature RequestMedium [PATCH] Turn Off LCD when closing the lid Closed
All Task Description Just added a few lines to, will power off the LCD when you close the LID. Patch attached.
 143 OpenPandora Main OSCoreBug ReportLow LED triggers timer and heartbeat cause freezing when us ...Closed
All Task Description Summary is about all i can dug out now. Somehow related to the PWM driving, because SD, bt and wifi leds work with trigger=timer. NOTE: power and charger leds are driven by PWM (just so you all know what I'm talking about). All i wanted to do was to add blinking power led to low power mode and all i get is a frozen pandora :/.
 131 OpenPandora Main OSCoreBug ReportMedium bluetooth drivers read timeout too trigger-happy/logic  ...Closed
All Task Description Shamelessly plugged from the forums, to get proper bug tracking and notifications on this. My post: @notaz: + /* there hould be no rx in progress at this point */ + if (info->rx_skb != NULL) { + dev_err(info->dev, "Receive timed out, %i done, %li left, " + "LSR=%02x, IER=%02x\n", info->rx_skb->len + 1, + info->rx_count, hci_h4p_inb(info, UART_LSR), + hci_h4p_inb(info, UART_IER)); + info->rx_timed_out = 1; + } Could you share your rationale for that comment in drivers/bluetooth/hci_h4p/core.c? (Oh and there's a typo, too :P ) EDIT: Asking this because commenting that block out changed status of bluetooth (for me) from unusable (can receive ~20-500kB of data before ppp connection halting) to fully working - used to have big problems playing 32kbps AAC stream (max 2 min), now already 4 mins of 96kbps, but i still think we need some receive timeout mechanism, but this one (as it currently stands) doesnt work. Notaz's reply: I don't really remember, it was more than 1.5 years ago. That driver is a hack, will need to review it, does it work stable with that code removed? My reply: For the non-IRC people: urjaman on IRC said: (22:47:45) urjaman: notaz: about stability: i'm on irc atm with that driver, its been playing internet radio for a few hours without problems now, but i don know for sure. (22:48:00) urjaman: *dont know (22:50:11) urjaman: my logic: if the serial port _never_ misses a byte it should be ok - IMO scary without some receive timeout, but works for me
 130 OpenPandora Main OSCoreFeature RequestLow [PATCH] in vsense mbuttons mode down=middle click Closed
All Task Description Patch attached.
 129 OpenPandora Main OSBase OSBug ReportMedium [PATCH] bluetooth script fails to store/restore bluetoo ...Closed
All Task Description Patch to attached.
Showing tasks 1 - 14 of 14 Page 1 of 1

Available keyboard shortcuts


Task Details

Task Editing