OpenPandora Main OS

Notice: Undefined index: tasklist_type in /srv/www/vhosts/openpandora.org/domains/bugs.openpandora.org/httpdocs/includes/class.tpl.php(136) : eval()'d code on line 228 Notice: Undefined index: tasklist_type in /srv/www/vhosts/openpandora.org/domains/bugs.openpandora.org/httpdocs/includes/class.tpl.php(136) : eval()'d code on line 233
  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Core
  • Operating System Release 1 (Zaxxon)
  • Severity Medium
  • Reported Version SuperZaxxon Final 1.53
Attached to Project: OpenPandora Main OS
Opened by Stefan Nowak - 2013-05-01
Last edited by Michael Mrozek - 2013-05-06

FS#317 - After disabling USB-host current still flows into USB device! Proof: device status LED still on

Tags:

On my Pandora, due to bad internal WiFi, I use an Edimax EW-7811Un USB WiFi adapter, which has a status-LED, flickering according to the network activity. After disabling USB-host through the settings menu, the WiFi functionality is gone, but the device's LED is still on. So some current must still flow into the USB device. The LED now has a permanent light, no flickering! This lack of "device intelligence" indicates that the device was indeed turned off, just current flowing directly to the LED circuit unaltered). I can repeat the aforementioned steps many times, the behavior is the same. As soon as I then first physically unplug and reinsert the device, the LED remains off eventually. From then on, every further issuing of "Disable USB-host" through the settings menu turns the device LED completely off. Smells like a kernel bug to me! As it requires one real un/re-plugging, from then on works ok.
Closed by  Michael Mrozek
Monday, 06 May 2013, 01:00 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Disabling the USB port only disables the driver chip to save power. It can not cut the hardware power traces to the port.
Joel Makarov

Wednesday, 01 May 2013, 22:30 GMT
That's a hardware issue. The wifi dongle will start drawing current as soon as you plug it in, regardless of whether the kernel module is enabled. The reason the LED remains off when you first plug it in is because it is only lit once initialised by the dongle's firmware, which doesn't happen until the OS interacts with it. - Neelix
Stefan Nowak

Thursday, 02 May 2013, 20:53 GMT
Because attachments still don't work as long as a year now (see:  FS#271 ) I cannot upload my carefully prepared graph with the aligned inline event log, so I suggest we follow up over at the forums: http://boards.openpandora.org/index.php/topic/12948-after-disabling-usb-host-current-still-flows-into-usb-device-proof-device-status-led-still-on-bug-report/

Loading...


Notice: Undefined variable: effort in /srv/www/vhosts/openpandora.org/domains/bugs.openpandora.org/httpdocs/includes/class.tpl.php(136) : eval()'d code on line 18 Notice: Trying to get property of non-object in /srv/www/vhosts/openpandora.org/domains/bugs.openpandora.org/httpdocs/includes/class.tpl.php(136) : eval()'d code on line 18 Warning: Invalid argument supplied for foreach() in /srv/www/vhosts/openpandora.org/domains/bugs.openpandora.org/httpdocs/includes/class.tpl.php(136) : eval()'d code on line 18
Date User Effort (H:M)