OpenPandora Main OS

Notice: Undefined index: tasklist_type in /srv/www/vhosts/openpandora.org/domains/bugs.openpandora.org/httpdocs/includes/class.tpl.php(136) : eval()'d code on line 228 Notice: Undefined index: tasklist_type in /srv/www/vhosts/openpandora.org/domains/bugs.openpandora.org/httpdocs/includes/class.tpl.php(136) : eval()'d code on line 233
  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Application
  • Operating System Release 1 (Zaxxon)
  • Severity High
  • Reported Version Hotfix 5
Attached to Project: OpenPandora Main OS
Opened by Stefan Nowak - 2011-08-11
Last edited by Grazvydas - 2013-01-02

FS#249 - File Browser Thunar - After 2 nub double-clicks unreactive to further mouse + keyboard input

Tags:

If I navigate via keyboard (KEY UP/DOWN to move in lists, ENTER level down, BACKSPACE level up) I experience no problems at all. I can go many levels up/down, change to other folders, etc. No problems. But if I navigate with the nubs, and using the right-nub-up-direction to trigger a double click, this only works 1-2 times, and from then on, the files/folders in Thunar cannot be clicked any further. I am stuck then. A look into dmesg reveals this: keyboard.c Can't emulate rawcode for keycode 139 The timestamp of that specific keyboard.c error messages exactly correlates with the bug occurrence times. (uptime timestamps matched with dmesg timestamps) I tried alternative filebrowsers such as emelFM2, and there the problem does not exist, meaning I can trigger as many double clicks I want! I am using HotFix 5 Alpha 4 on an SD card. The bug already annoyed me on a HF5 on the NAND.
Closed by  Grazvydas
Wednesday, 02 January 2013, 12:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in SuperZaxxon 1.52 + "System->Upgrade pandora OS"
Nils Kneuper

Sunday, 28 August 2011, 13:37 GMT
This bug is a duplicate of Bug  FS#157  (though it describes stuff in more detail). cf http://bugs.openpandora.org/index.php?do=details&task_id=157
Stefan Nowak

Sunday, 28 August 2011, 14:10 GMT
I hope though that my detailed description helps for the debugging process.
Stefan Nowak

Thursday, 01 September 2011, 14:01 GMT
Stefan Nowak

Friday, 21 October 2011, 21:32 GMT
Bug still exists in Pandora OS 1.6.
bukkit

Thursday, 16 August 2012, 13:38 GMT
Bug confirmed for Thunar 1.0.2, SuperZaxxonFinal 2012-06. Mind: This only happens with the list views, "Detailed List" and "Compact List". Icon view is unaffected.
Stefan Nowak

Thursday, 16 August 2012, 14:14 GMT
Interesting to know that only "List mode" is affected. Always wondered why the complaint about this was not more popular, as a file browser is used on a daily basis. But as "Icon view" is the default view, probably only few users experienced that bug. Until that basic functionality is not solved it is a shame to call the OS revision "final". Hope that this fix will happen.
bukkit

Monday, 27 August 2012, 14:53 GMT
I lately experienced a case where only "Detailed List" was affected. Compact List was working.
Urja Rannikko

Saturday, 29 December 2012, 11:26 GMT
https://bugzilla.xfce.org/show_bug.cgi?id=6230 We could apply the patch to exo available from that link.
Stefan Nowak

Saturday, 29 December 2012, 14:56 GMT
As a user I can say: The bug description over there is exactly matching our bug. I kindly ask a dev to apply that patch into the firmware.
Grazvydas

Saturday, 29 December 2012, 18:50 GMT
I've upgraded exo to 0.3.107 instead, which seems to have that patch applied already. If you have SZ 1.52, please try "System->Upgrade pandora OS" or "opkg update; opkg upgrade", then logout and log back in.
Stefan Nowak

Tuesday, 01 January 2013, 23:28 GMT
Tested and it works! What a relief! One step closer for SuperZaxxon to deserve the label "Final".

Loading...


Notice: Undefined variable: effort in /srv/www/vhosts/openpandora.org/domains/bugs.openpandora.org/httpdocs/includes/class.tpl.php(136) : eval()'d code on line 18 Notice: Trying to get property of non-object in /srv/www/vhosts/openpandora.org/domains/bugs.openpandora.org/httpdocs/includes/class.tpl.php(136) : eval()'d code on line 18 Warning: Invalid argument supplied for foreach() in /srv/www/vhosts/openpandora.org/domains/bugs.openpandora.org/httpdocs/includes/class.tpl.php(136) : eval()'d code on line 18
Date User Effort (H:M)