Notice: Trying to access array offset on value of type bool in /srv/www/vhosts/ on line 649 FS#222 : Login Screen does not accept all symbols of the form Fn+char

OpenPandora Main OS

  • Status Unconfirmed
  • Percent Complete
  • Task Type Bug Report
  • Category Application
  • Operating System Release 1 (Zaxxon)
  • Severity Low
  • Reported Version Hotfix 5
Attached to Project: OpenPandora Main OS
Opened by Nicholas - 13.03.2011

FS#222 - Login Screen does not accept all symbols of the form Fn+char

Problem - Login Screen does not accept all symbols of the form Fn+char Reproducibility - always Actual results - the characters :?#|$€"‘£¥@!_ do not work on the Login Screen with the Pandora's keyboard. When fn then the corresponding character is pressed, nothing is added to the string. Expected results - these characters should appear just like any other character Work Around - an external keyboard was able to enter these characters Aditional Information - While the characters :?#|$€"‘£¥@!_ do not work, the characters ;/\'-+=`() work just fine.
Tim Okrongli commented on 18.03.2011 18:42
Yup, definitely happens. Also, USB keyboards don't help at least on the first login.
Nicholas commented on 18.03.2011 21:40
For me, a USB keyboard connected to a hub worked just fine. Are you sure the USB keyboard you were using was USB2.0 (that's why I used the hub)? Did it work with other characters?
Tim Okrongli commented on 19.03.2011 13:42
No, I thought that you can operate USB 1 devices on the OTG port. That's why nothing happened.
Stefan Nowak commented on 21.01.2013 16:10
This get's reported again and again under different keywords such as: login, password, keymap, special characters, etc. And indicator that a fix would be needed.
Joel Makarov commented on 21.01.2013 20:27
I would add that that use of a USB keyboard is no longer a useful work-around for this as the USB port is now disabled by default.
Carlos Lange commented on 03.02.2013 21:53
To add insult to injury, at least the exclamation mark (!) is accepted by the initial setup dialogue, so that the password was hashed with it, but I could never re-enter the same password for my first real login. I had to re-flash a brand new Pandora, because of this.
Grazvydas commented on 05.02.2013 01:24
Ok spent several hours trying to make slim login manager load xmodmap with no success and resorted to hacking it's code. Try "System->upgrade pandora's OS" and see if it works now..
Joel Makarov commented on 05.02.2013 07:57
That seems to work. I added a user with a ! and a _ in the password and then was able to successfully login to the account both when logging to XFCE and into the CLI mode. I like that this also seems to have made it possible to enter these punctuation characters once logged into the CLI mode. :-) You seem to have killed the custom Pandora background image on the login screen though. BTW is there any chance of putting a build number on the splash screen for these incremental builds?
Joel Makarov commented on 09.02.2013 15:50
In addition to overwriting the op SLiM theme, this update also clears the currently selected default user, with the effect that auto login and automatic username population seem to break with the upgrade,
Grazvydas commented on 10.02.2013 15:02
Yeah it was reverting user's config to default one, that also should be fixed now (update no longer touches config).


Available keyboard shortcuts


Task Details

Task Editing