OpenPandora Main OS

Notice: Undefined index: tasklist_type in /srv/www/vhosts/openpandora.org/domains/bugs.openpandora.org/httpdocs/includes/class.tpl.php(136) : eval()'d code on line 228 Notice: Undefined index: tasklist_type in /srv/www/vhosts/openpandora.org/domains/bugs.openpandora.org/httpdocs/includes/class.tpl.php(136) : eval()'d code on line 233
  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Core
  • Operating System Release 1 (Zaxxon)
  • Severity High
  • Reported Version Hotfix 4
Attached to Project: OpenPandora Main OS
Opened by Michael Mrozek - 2011-01-23
Last edited by Michael Mrozek - 2011-02-23

FS#201 - PND apps still use memory after they've quit

Tags:

After running and quitting a PND app, not all of the used memory is being freed. This eats more and more memory over time. Just run 5 or 6 apps and you only have half of the memory left. Sounds like either aufs or unionfs don't free the memory after unmounting. This has been reported with HF4 and still is the case with HF5 Beta 2 -- downgraded to 'Researching' and 'Normal' priority until confirmed and details found
Closed by  Michael Mrozek
Wednesday, 23 February 2011, 00:08 GMT
Reason for closing:  Works for me
Jeff

Thursday, 17 February 2011, 00:49 GMT
Do we have additional details? I've tried on two pandoras (hf1 and hf5 (beta right before rc1) with no problems.) I'm using 'top' and 'free' to check for RAM. I can run 3 random pnd's in a row, no problem. (ie: such as snes9x4p, from pickle launcher into emu and back out to xfce.) We need a list of steps to reproduce including... 1) firmware version 2) step to simulate _Starting from fresh boot_; ideally, right after fresh reflash as well, in case personal mods have been aplied that cause it. -- ex: reflash, then fresh boot, then run pnd foo (download link) and pnd bar (download link) and pnd baz (download link), with top or free reports before/after each step. The problem may well exist, but I think we need more details -- there _Are_ some pnds that live past the life of the pnd (they run background daemons, for example), and _will_ eat up ram, but those are pretty rare. For example, Powder is buged (a bad run script, that forks and exits right away, so the pnd tries ot unmount immediately but fails since tghe forked side is still up), so it eats up ram and does not unmount. Thetre are a few like that. jeff
Jeff

Thursday, 17 February 2011, 00:51 GMT
IS there a thread on gp32x or openpandora boards with details perhaps?
Jeff

Thursday, 17 February 2011, 00:55 GMT
I tried a few GLES apps as well; they merely caused additional caching, not memory loss. Are folks being confused by 'truly free' memory versus 'cached memory'? jeff
Michael Mrozek

Wednesday, 23 February 2011, 00:08 GMT
True, seems to be cached memory. Retried using top and seemed to work fine.

Loading...


Notice: Undefined variable: effort in /srv/www/vhosts/openpandora.org/domains/bugs.openpandora.org/httpdocs/includes/class.tpl.php(136) : eval()'d code on line 18 Notice: Trying to get property of non-object in /srv/www/vhosts/openpandora.org/domains/bugs.openpandora.org/httpdocs/includes/class.tpl.php(136) : eval()'d code on line 18 Warning: Invalid argument supplied for foreach() in /srv/www/vhosts/openpandora.org/domains/bugs.openpandora.org/httpdocs/includes/class.tpl.php(136) : eval()'d code on line 18
Date User Effort (H:M)